Results 1 to 3 of 3
Like Tree1Likes
  • 1 Post By Le-Bisousnours

Thread: Security Permissions issue

  1. #1
    Thunderbolt is offline
    (Jack)
    Thundercunt. Member Thunderbolt's Avatar
    Join Date
    November 26th, 2010
    Location
    Maine
    Age
    17
    Gender
    Posts
    236

    Default Security Permissions issue


    *Ads Disappear After 100 Posts*
    So, I pulled the hard drive out of my sisters like really old laptop, and put it in my enclosure. Now, I'm trying to get stuff off of it, and it doesn't want to let me do anything with the pictures that are there. I make it so I can view them (with windows photo viewer), but then It won't let me anyway.. I get a message saying "Windows Photo Viewer can't open this picture because you don't have the correct permissions to access the file location.". How do I fix this? The hard drive is formatted for XP. I'm running 7.
    lawl.

    Quote Originally Posted by Casey View Post
    Are we talking the Christian extreme third base, making eye contact?


    • Advertising


  2. #2
    The Chill Member frosty's Avatar
    Join Date
    September 18th, 2011
    Location
    USA
    Gender
    Posts
    1,841

    Default Re: Security Permissions issue

    I had the same problem upgrading from Vista to 7.

    I'm not sure what tool I used, but I had to go into the hard drive from a program, not Explorer. Try Norton Ghost if you've got it, I'll try to think of the one I used

  3. #3
    Le-Bisousnours is offline
    (Elliot Bastiani)
    The Cuddly Banned
    Join Date
    April 27th, 2011
    Location
    Dordogne, France
    Age
    19
    Gender
    Posts
    2,467

    Default Re: Security Permissions issue

    The problem is those files are still under the "control" of the Administrator of the old computer. One way to fix this:

    Open up Notepad on the PC from which you are trying to access the files, and copy-paste this into it:

    Code:
    Windows Registry Editor Version 5.00
    
    [HKEY_CLASSES_ROOT\*\shell\runas]
    @="Grant Admin Full Control"
    "NoWorkingDirectory"=""
    
    
    [HKEY_CLASSES_ROOT\*\shell\runas\command]
    @="cmd.exe /c takeown /f \"%1\" && icacls \"%1\" /grant administrators:F"
    "IsolatedCommand"="cmd.exe /c takeown /f \"%1\" && icacls \"%1\" /grant administrators:F"
    
    
    [HKEY_CLASSES_ROOT\exefile\shell\runas2]
    @="Grant Admin Full Control"
    "NoWorkingDirectory"=""
    
    
    [HKEY_CLASSES_ROOT\exefile\shell\runas2\command]
    @="cmd.exe /c takeown /f \"%1\" && icacls \"%1\" /grant administrators:F"
    "IsolatedCommand"="cmd.exe /c takeown /f \"%1\" && icacls \"%1\" /grant administrators:F"
    
    
    [HKEY_CLASSES_ROOT\Directory\shell\runas]
    @="Grant Admin Full Control"
    "NoWorkingDirectory"=""
    
    
    [HKEY_CLASSES_ROOT\Directory\shell\runas\command]
    @="cmd.exe /c takeown /f \"%1\" /r /d y && icacls \"%1\" /grant administrators:F /t"
    "IsolatedCommand"="cmd.exe /c takeown /f \"%1\" /r /d y && icacls \"%1\" /grant administrators:F /t"
    Now save the file as "GrantAdminFullControl.reg" (it NEEDS to be ".reg"). Open it up and allow the keys to install into the registry.

    Now go to where the pictures are located, select them all, right-click and chose the new "Grant Admin Full Control" option that should be there (may require a refresh or restart of your PC).

    BAM! You just gave yourself control of the files!

    [[ That should do the trick. If it doesn't then... well... I don't know ]]
    frosty likes this.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •